Your Android device is compatible.

If your smartphone has Android 4 or a newer version installed, you are ready for the new SBB Mobile.

Please check whether your phone is set to update apps automatically or open the Play Store to update SBB Mobile manually.

Activate automatic updates.

Further content